Treat acronyms and abbreviations as words in naming variables, methods, and classes. The names are much more readable:
Good | Bad |
---|---|
XmlHttpRequest | XMLHTTPRequest |
getCustomerId | getCustomerID |
class Html | class HTML |
String url | String URL |
long id | long ID |
Both the JDK and the Android code bases are very inconsistent with regards to acronyms, therefore, it is virtually impossible to be consistent with the code around you. Bite the bullet, and treat acronyms as words.
For further justifications of this style rule, see Effective Java Item 38 and Java Puzzlers Number 68.