Eclipse Android Requires Compiler Compliance Level

After importing an existing Android application into a new workspace the following error can occur: “Your Project contains error(s), please fix them before running your application.”

First thing to do is to look at the console output and read the error. In this case it told what the problem is and how to solve it!

“Android requires compiler compliance level 5.0 or 6.0. Found ‘1.4’. Please use Android Tools -> Fix Project Properties.”

Right click your project, navigate to Android Tools and select Fix Project Properties. Now the error is fixed and the Android Application can run as normal.

Posted in Android, ErrorFix, Linux, Mac, Windows Tagged with: , , , , ,